Terrible LAS Performance

Post Reply
mchootie
Posts: 1

Terrible LAS Performance

Post by mchootie » Fri Jul 26, 2019 8:15 am

Hello All,

I have been adjusting every setting I can in order to get the LAS scenery running above 25-30fps on my system with dives into the mid teens 10-15fps. This scenery is the only payware scenery that drastically sticks out as under performing on my system.

I have disabled every performance hitting piece of eye candy in the Fly Tampa config as well as in the P3D settings. I am now at a loss.

P3D v4.5

Terrain Addons

Orbx Global
Orbx NA LC


My PC:

MSI Trident X Plus
Intel i9-9900K OC to 4.7Ghz
16 GB DDR4 Ram
RTX2080
512 GB SSD


Thank you for the help!
Ezra
Posts: 1

Re: Terrible LAS Performance

Post by Ezra » Thu Aug 01, 2019 2:29 pm

mchootie wrote:
Fri Jul 26, 2019 8:15 am
Hello All,

I have been adjusting every setting I can in order to get the LAS scenery running above 25-30fps on my system with dives into the mid teens 10-15fps. This scenery is the only payware scenery that drastically sticks out as under performing on my system.

I have disabled every performance hitting piece of eye candy in the Fly Tampa config as well as in the P3D settings. I am now at a loss.

P3D v4.5

Terrain Addons

Orbx Global
Orbx NA LC


My PC:

MSI Trident X Plus
Intel i9-9900K OC to 4.7Ghz
16 GB DDR4 Ram
RTX2080
512 GB SSD


Thank you for the help!
This Flight Sim Hobby is somewhat of a "black art" when trying to achieve good visuals and performance.

I have similar system as you. Except more ram (more ram has a significant effect in terms of smoothing things out, but not so much in extra frames). The following are the settings I use to bring up smoother FPS with this add-on.

I use default settings in the FlyTampa Installer with a few minor tweaks. However, I made the following changes in the P3D settings and I run at 4K. But don`t expect much more than an average of 30 FPS (smooth) performance. 30 FPS is the benchmark now-a-days with top end system @4K in regards to P3Dv4.5 with multiple add-ons. Having said this, it is getting better but at a slower pace than the software developers. This, of course, is understandable since the add-on developers need to future proof things in terms of development cycles and economics coupled with hardware evolution.

Try the following Settings with Terrain maxed out (P3D settings).
However, Scenery Objects are not maxed out!
Scenery Complexity: Normal
Autogen and scenery draw distance: High
Autogen vegetation density: Normal
Autogen building density: Normal

Turn off special effects. Make sure dynamic lights are enabled. Shadows to taste (I use ultra).

Frame Rate Controls: VSync on, Triple Buffering on, Target frame rate: Unlimited.

It also helps to set Nvidea Control Panel (Program Setting) to Vertical sync: fast and Prefer maximum performance in the Power management mode. Leave all else on default, including the Global Settings in Nividea Control Panel.

With these setting I get a fairly smooth performance (24-45 FPS) with Quality Wings 787 and thing look good as well.

Note: Keep notes and use the save feature in the Display Global Settings (P3D). Example: 4K Settings, IFR settings, VFR setting, etc. This way you can quickly reset things for the type of flight planning and experiences you desire on a given day.

I hope this helps some. Cheers.
bluefly330
Posts: 7

Re: Terrible LAS Performance

Post by bluefly330 » Tue Sep 24, 2019 5:38 am

Hi,
same problem here getting 8-12 fps (not smooth)

Intel i7-3770 3.4GHz
16GB RAM
GTX960 4GB

all my other sceneries are working great and for the most part smooth but sadly not this one. Since release i´m not able to fly into Las Vegas because the terrible performance makes it unflyable, even with default airctafts.

My scenery settings in the configurator are to a minimum but that doesn´t seem to help
SolRayz
Posts: 8

Re: Terrible LAS Performance

Post by SolRayz » Tue Oct 01, 2019 9:02 pm

mchootie wrote:
Fri Jul 26, 2019 8:15 am

Frame Rate Controls: VSync on, Triple Buffering on, Target frame rate: Unlimited.

It also helps to set Nvidea Control Panel (Program Setting) to Vertical sync: fast and Prefer maximum performance in the Power management mode. Leave all else on default, including the Global Settings in Nividea Control Panel.
FYI...if you enable V-Sync in sim, it negates V-Sync settings in Nvidia control panel. Its one or the other.
Voltron
Posts: 2

Re: Terrible LAS Performance

Post by Voltron » Sat Oct 26, 2019 8:16 am

I can without a doubt that this is one of the worst sceneries i have ever purchased and deffinetly the worst scenery i have puchased from flytampa. No rookie to sims, ive been flying with different payware for awhile and im comfortable saying my system is not the worst system and not the best. Ive bought many sceneries that were top notch and i have not had to change i think on my setting. I have messed around with this KLAS scenery trying to figure out what it is thats causing a major hit to my system. Bottom line, it is the las vegas city its self. The fact that the city is already close to the airport doesnt make it any better also. FLYTAMPA, your city is too dense and there is no tool to adjust this unless i adjust my entire world density. Not willing to do that so i sugges that you come up with a tool or an alternate bgl with a less dense vegas city. Paying customers deserve an answer to this months ago.
emilios[flytampa]
Site Admin
Posts: 935

Re: Terrible LAS Performance

Post by emilios[flytampa] » Sat Oct 26, 2019 1:21 pm

I havent found any performance bottleneck in Vegas. With default settings it does in fact run smoother than Copenhagen which is a 5 year old scenery. I dont know what else might be running in the background on your system, but the scenery is exhaustively tested, so there is not much to change that would help. Perhaps reduce some P3D visual settings if your system cant handle it.

if that offers any comparison, i m using a dated i5-2500K and gtx980ti.


if unusable, let us know by emailing support@flytampa.com
simtom
Posts: 1

Re: Terrible LAS Performance

Post by simtom » Sun Oct 27, 2019 8:09 pm

For some reason I get huge FPS spikes when flying near Las Vegas (or standing at a gate). I goes from 5 FPS to a comfortable 25 FPS. I should mention that anything above 20 FPS is rather hard to achieve, but still the sim manages to hold that for a couple of seconds. I was using the PMDG 747-8 at the time (which is quite easy on performance).

I've tried the following settings with no noticeable change in performance:
- Dynamic Lighting on/off
- AI Traffic on/off
- V-Sync on/off

What I did not test was setting the sim to noon or any time that doesn't turn on the lights.

My system specs are:
- i7-4770K (OC to 4.3)
- GTX 1070
- 16GB RAM

I feel like this isn't at the base of my problem because the admin above me has a less powerful system.

Maybe I should try turning down the apron detail and traffic?
emilios[flytampa]
Site Admin
Posts: 935

Re: Terrible LAS Performance

Post by emilios[flytampa] » Sun Oct 27, 2019 10:42 pm

On the FT configurator, the description text would give you an indication of the relevant performance hit of each option. Most noticeable changes would be seen with tuning down the apron traffic mode to 'simple', or from the Las Vegas city tab, try turning some of the animations and effects off, or the dynamic lighting on the highroller
Post Reply